Помогите составить программу в паскале, срочно надо 141в

0 голосов
23 просмотров

Помогите составить программу в паскале, срочно надо 141в


image

Информатика (255 баллов) | 23 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var x,y,h:real; n,i:integer;
begin
write('h = ');
readln(h);
write('n = ');
readln(n);
for i:=0 to n do
 begin
 x:=1+i*h;
 y:=(x*x-3*x+2)/sqrt(2*x*x*x-1);
 writeln(x:4:1,'  ',y:7:4);
 end;
end.

Пример:
h = 0.1
n = 5
1.0 0.0000
1.1 -0.0698
1.2 -0.1021
1.3 -0.1140
1.4 -0.1133
1.5 -0.1043

(194k баллов)