1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей....

0 голосов
67 просмотров

1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет.

2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр.

3. Составьте программу в Pascal ABC. Дано двузначное число. Вывести число, полученное при перестановке цифр.


Информатика (39 баллов) | 67 просмотров
Дан 1 ответ
0 голосов

1.
var a: real;
      x,y: integer;
begin
         readln(x,a,y);
         writeln('1 kg konfet stoit ', a/x:1:2);
         writeln(y,' kg konfet stoyat ', a/x*y:1:2);
         readln;
end.
2.
var a,s,p: integer;
begin
         readln(a);
         s:=a mod 10 + a div 10;
         p:=(a mod 10)*(a div 10);
         writeln(s);
         writeln(p);
         readln;
end.
3.
var a,b: integer;
begin
         readln(a);
         b:=(a mod 10)*10+(a div 10);
         writeln(b);
         readln;
end.
Это если без циклов.

(2.1k баллов)