Напишите программу ** С#, которая будет менять в заданном в программе массиве целых чисел...

0 голосов
54 просмотров

Напишите программу на С#, которая будет менять в заданном в программе массиве целых чисел все элементы, которые равны указанному значению, на противоположное по знаку. Реализовать программу следует с использованием функции, в которую изменяемое значение передаётся в качестве аргумента. Например, все элементы массива, которые равны 2,будут меняться на -2.


Информатика (49 баллов) | 54 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Using System;

public class Test
{
public static int change(int x){return -x;}
public static void Main()
{
const int n=5;
int[,] a=new int[n,n];
Random rnd=new Random();
Console.Write("введите число:");
int c=int.Parse(Console.ReadLine());
Console.WriteLine("");
Console.WriteLine("исходный массив:");
for(int i=0;i {
for(int j=0;j {
a[i,j]=rnd.Next(1,10);
Console.Write(a[i,j]);
}
Console.WriteLine("");
}
Console.WriteLine("полученный массив:");
for(int i=0;i {
for(int j=0;j {
if(a[i,j]==c) a[i,j]=change(c);
Console.Write(a[i,j]);
}
Console.WriteLine("");
}
}
}

(149k баллов)
0

спасибо огромное