Написать программу ** языке программирования высокого уровня С++ вычисляющую количество...

0 голосов
30 просмотров

Написать программу на языке программирования высокого уровня С++ вычисляющую количество введенных чисел и максимальный элемент из входного потока. Данные ввести с клавиатуры и записать во внешний файл на диске. Количество введенных чисел не ограничено. Признак окончания ввода чисел во входном потоке - число 421.
После записи введенных данных в конец файла дописать количество введенных чисел и максимальное введенное число. Например, Количество введенных чисел - 12, максимальное среди введенных - 345, причем признак окончания ввода - последнее число 421 не учитывать.


Информатика (12 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

#include
#include


int main()
{
    setlocale(LC_ALL, "RUSSIAN");
    std::ofstream file("file.txt");
    int cr=0;
    int max = 0;
    int count = 0;
    do
    {
        std::cout << "Введите число >> ";
        std::cin >> cr;
        if (cr > max)
            max = cr;
        if(cr!=421)
            file << cr << std::endl;<br>        count++;
    } while (cr != 421);
    file << "Количество введенных чисел: " << count << std::endl;<br>    file << "Максимальное введенное число: " << max << std::endl;<br>}

(1.5k баллов)