Программирование алгоритмов ветвления .Составить программу ** Pascal

0 голосов
852 просмотров

Программирование алгоритмов ветвления .Составить программу на Pascal


image

Информатика (64 баллов) | 852 просмотров
0

Расскажите про "противный случай", пожалуйста.

Дан 1 ответ
0 голосов

Противный случай - это то же самое, что в другом случае или на языке информатики "иначе".
По-моему, в вашем случае "противного случая" нет, т. к. все возможные значения х учтены в первых случаях: число х может быть меньшим 0, большим 0, или равным 0. Но, если не придираться к условию, то программа выглядит так:

program funkciya;
 var x, y: real;
begin
write('x='); readln(x);
if x<0 then y:=sin(sqr(x)) + 2*x<br>           else if x>=0 then y:=sqrt(x)+sqrt(sqr(x)+1)
                                else y:=cos(x);
write('y=',y:5:2)
end.

(51.1k баллов)