Написать программу, которая позволяет просматривать текстовые файлы (выводит ** экран...

0 голосов
48 просмотров

Написать программу, которая позволяет просматривать текстовые файлы (выводит на экран содержимое файла) , например, файлы исходных программ Turbo Pascal. Имя просматриваемого файла должно вводится во время работы программы. Рекомендуемый вид экрана приведен ниже. Просмотр текстового файла. Введите полное имя файла и нажмите . -> d:\tp\pas\numb.pas


Информатика (26 баллов) | 48 просмотров
0

плииз(((

Дан 1 ответ
0 голосов

Var f1:text;
st:string;
begin
write ('введите имя файла ');
readln(f1);
reset (f1); { открыть файл для чтения }
while not eof (f1) do { пока не конец файла  f1}
begin
readln (f1, st);    {читаем строку из файла f1 }
writeln(st);         { выводим на экран }
end;
close (f1); { закрыть файл  для чтения}
end .

(90 баллов)