Написать программу в Pascal Найти: y=x^4+3/3x ** промежутке [4;10] с шагом 0.1...

0 голосов
61 просмотров

Написать программу в Pascal Найти: y=x^4+3/3x на промежутке [4;10] с шагом 0.1 Использовать цикл с постусловием


Информатика (12 баллов) | 61 просмотров
0

+3/3x ?

Дан 1 ответ
0 голосов

Const
  dx = 0.1;
  l = 4;
  r = 10;
var
  x,y:real;
begin
  x := l;
  repeat
    y := sqr(sqr(x)) + 1/x;
    writeln(x:4:1,' : ',y:0:3);
    x := x + dx;
  until x > r;
end.

(8.5k баллов)