Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль....

0 голосов
26 просмотров

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)
Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:
Найти номера первых двух рядом
стоящих одинаковых элементов в массиве.


Например, если А={2,6,4,4,2,5,5,4},
результат: 3 и 4.


Информатика (34 баллов) | 26 просмотров
0

а нужно только цикл написать а массив у вас уже есть? или рандомно заполнить массив?

0

написать программу полностью, массива у меня еще нет

0

а массив желаете сами заполнить или автоматом?

0

автоматом

0

чет переписывать лень

Дан 1 ответ
0 голосов

Program random_;
uses crt;
type
arr = array[0..1000] of shortint;
var
ar,b,i:word;
a:arr;
begin
randomize;
for ar:=0 to 999 do
a[ar]:= random(18)-9;

b:=10;
i:=0;
repeat b:=a[i]; i:=i+1; until(b = a[i]) or (i = 999);

if i = 999 then writeln('Повторяющихся чисел нет!') else writeln(i,' ',i+1) ;

end.

(402 баллов)
0

ооо спасибо большое!!!))) сможете еще с одной задачей помочь в Паскале?