Написать программу, которая вычисляет частное двух чисел. Программа должна проверять...

0 голосов
181 просмотров

Написать программу, которая вычисляет частное двух чисел. Программа должна проверять правильность введенных пользователем данных и, если они неверные (делитель равен нулю), выдавать сообщение об ошибке. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).
Вычисление частного.
Введите в одной строке делимое и делитель,
затем нажмите
-> 12 0
Вы ошиблись. Делитель не должен быть равен нулю. (С++))
Пожалуйста на С ++


Информатика (29 баллов) | 181 просмотров
Дан 1 ответ
0 голосов

#include
using namespace std;

int main()
{
int a, b;
cout << "Enter the dividend and divisor: " << endl;<br>cin >> a >> b;
if (b == 0) {
cout << "You are mistaken. The divisor can not be zero." << endl;<br>cin >> b;
} else {
cout << "Result: " << (double)a / b << endl;<br>}
return 0;
}

(4.2k баллов)
0
0

Здраствуйте а что за ссылку вы мне скинули?

0

там код + тесты, там просто лучше видно его