С++ Напишите программу, которая вводит два вещественных числа (x и y) и вычисляет...

0 голосов
226 просмотров

С++ Напишите программу, которая вводит два вещественных числа (x и y) и вычисляет значение x^y.


Информатика (57 баллов) | 226 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

#include

int main()
{
    float x, y;
    float res = 1;
    std::cin >> x >> y;
    for (int i = 0; i < y; i++)
        res *= x;
    std::cout << res << std::endl;<br>}

(1.5k баллов)
0 голосов
function Power(x,y:real):real;
{ (C) Puporev }
begin   if x=0 then     Power:=0  
else    
if x>0 then      
 Power:=exp(ln(x)*y)  
  else      
 Power:=-exp(ln(abs(x))*y);
end;
  var  x,y:real;
begin
 readln(x,y);
 writeln(power(x,y));
end.
(18 баллов)