Даны три целых числа.Написать программу выводящую те из них которые больше нуля и...

0 голосов
37 просмотров

Даны три целых числа.Написать программу выводящую те из них которые больше нуля и подсчитывающую их произведение.И сделайте блок-схему.


Информатика (69 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

Var a,b,c,p:integer;
begin
  readln(a,b,c);
  if a>0 then begin p:=p*a; writeln(a); end;
  if b>0 then begin p:=p*b; writeln(b); end;
  if c>0 then begin p:=p*c; writeln(c); end;
  writeln('произведение:',p);
end.


image
(7.2k баллов)