1) Написать программу , которая выводит сумму всех чисел , кратных 3 от 3 до 3000. 2)...

0 голосов
48 просмотров

1) Написать программу , которая выводит сумму всех чисел , кратных 3 от 3 до 3000.
2) Написать программу на Паскале.
Бегун в первый день пробежал 5 км. Каждый следущий день он увеличивал длину пробега на 10% от предыдущего дня . Определите в какой день он пробежит больше 20 км, в какой день суммарный пробег за все дни превысит 100км.


Информатика (12 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

Program p1;
var i,sum:integer;
begin
sum:=0;
for i:=3 to 3000 do
  if i mod 3 = 0 then sum:=sum+i;
writeln(sum);
end.

program p1;
var i,d1,d2:integer;
sum,x:real;
begin
x:=5;
sum:=0;
i:=0;
while x <= 20 do<br>  begin;
  i:=i+1;
  x:=x*1.1;
  end;
writeln('Больше 20км в ' ,i, ' день');
x:=5;
sum:=0;
i:=0;
while sum<=100 do<br>  begin;
  i:=i+1;
  sum:=x+sum;
  x:=x*1.1;
  end;
writeln('Суммарный пробег превысит 100км в ' ,i, ' день');
end.

(887 баллов)