Помогите! Язык Си Написать программу,которая находит количество простых членов...

0 голосов
39 просмотров

Помогите! Язык Си
Написать программу,которая находит количество простых членов последовательности.


Информатика (174 баллов) | 39 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
using namespace std;

int main()
{
    setlocale(LC_ALL,"RUS");
    int N;
    cout <<"Введите количество чисел: ",cin >> N;
    cout <<"Введите сами числа: ";<br>    int k = 0;
    for(int i = 0; i < N; i++)
    {
        int A;
        cin >> A;
        if (A > 3)
        {
            int B = 1, K = sqrt(A), d = 2;
            while(d <= K)<br>            {
                if (A % d++ == 0)
                {
                    B = 0;
                    break;
                }
            }
            if (B) k++;
        }
        else if (A > 1) k++;
    }
    cout <<"Количество простых, среди введённых: "<<k;<br>    return 0;
}

(6.6k баллов)