Очень срочно Помогите плиз!!! Написать программу табуляции функции у=1/х ** отрезке...

0 голосов
55 просмотров

Очень срочно Помогите плиз!!!

Написать программу табуляции функции у=1/х на отрезке [-2,2] с шагом 1 на языке Паскаль.

есть черновой вариант

Program A; uses crt; var x, y, n: real; begin clrscr; x:=-2; n:=2; writeln('----------------'); writeln (' x y '); writeln('----------------'); while x<=n do begin y:=1/x; writeln (x:3:0,y:8:2); x:=x+1; end; writeln('----------------'); writeln('Конец '); end.<br>На выходи выходит это


image

Информатика (44 баллов) | 55 просмотров
0

черновой вариант как бы и есть программа, которую требуется написать, не?

0

т.е это правильно?

0

да, это верное решение.

Дан 1 ответ
0 голосов
Правильный ответ

Так будет красивее и правильнее

uses crt;
const
    x0 = -2;
    xn = 2;
    dx = 1;

var
    x: real;

begin
    clrscr;
    x := x0;
   
    writeln('----------------');
    writeln('x':3, 'y':8);
    writeln('----------------');
    repeat
        writeln(x:3:0, '  ', (1 / x):8:2);
        x := x + dx;
    until x > xn;
    writeln('----------------');
    writeln('Конец ');
end.

(55.0k баллов)
0

тогда можно было бы ещё меньше переменных использовать

0

куда уж меньше - одна

0

константы не переменные

0

с удовольствием рассматрю ваше решение если вы его выложите

0

константа - тоже переменная, только фиксированная и неизменяемая!

0

Паскалевский компилятор заменяет имя константы её значением, затем сворачивает константные выражения, и только потом генерирует код. Так что, никаких ячеек в оперативной памяти не используется, и обращений к ним тем более нет.