Задание по информатике 10 класс напишите программу, по которой из текстового файла с...

0 голосов
88 просмотров

Задание по информатике 10 класс напишите программу, по которой из текстового файла с именем kvur.txt будут прочитаны три числа- a,b,c коэффициенты квадратного уравнения, затем будут вычеслены корни этого уравнения и выведены на экран и в текстовой файл korni.txt.


Информатика (12 баллов) | 88 просмотров
Дан 1 ответ
0 голосов

//Код Pascal:
Var
   f:text;
   a,b,c,D:real;
Begin
Assign(f,'kvur.txt');
Reset(f);
ReadLn(f,a,b,c);
Close(f);
Assign(f,'korni.txt');
Rewrite(f);
D:=b*b-4*a*c;
c:=(-b-Sqrt(D))/(2*a);
a:=(-b+Sqrt(D))/(2*a);
if D >= 0 then
   Begin
   WriteLn(c,' ',a);
   WriteLn(f,c,' ',a)
   End
else
   Begin
   WriteLn('Действительных корней нет.');
   WriteLn(f,'Действительных корней нет.')
   End;
Close(f);
ReadLn;
End.

Для корректной работы программы файлы должны находиться в одной папке с программой.


Скачать вложение Текст (TXT)
Скачать вложение Текст (TXT)
(6.6k баллов)