Написать программу, которая будет принимать числа от пользователя до тех пор пока не...

0 голосов
120 просмотров

Написать программу, которая будет принимать числа от пользователя до тех пор пока не будет введен ноль. После того как пользователь ввел все числа она должна вывести сумму всех введенных чисел и произведение, возведенное в квадрат.
Dim a, b, C As Single
'c -это произведение
'b- это сумма
b = 0
C = 1
For i = 1 To 10000
Console.Write("введите a= ")
a = Console.ReadLine
If a > 0 And a < 0 Then
b = b + a
C = C * a
Else
b = b ^ 2
C = C ^ 2

End If
Next
Console.WriteLine("b=" & b & "с=" & C)
Console.ReadLine()
Что не так?Не могу понять.Помогите пожалуйста!


Информатика (32 баллов) | 120 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Делайте что-то типо
int m = 1;
while(true) // нескончаемый цикл
{
cout << "Enter number: " << endl; // просим ввести число<br>cin >> m;
if (m == 0) // проверяем равно ли 0
{
// если да(т.е. мы встретили 0), тут делаем  нужные вычисления
break; // и уже потом выходим из цикла
}
}

(4.2k баллов)
0

вы удивитесь,но я не понял что вы написали,я это вроде не проходил(

0

можете исправить ошибки?

0

я не понял что за язык вы используете возможно C#? но типо сначала инициализируем число у нас это int m = 1, затем делаем нескончаемый цикл while(true), потом делаем проверку равно ли число 0 if (m == 0) если да выходим из цикла break

0

я писал на С++, ну и конечно ещё одно, после как пользователь ввел число, спрашиваем хочет ли он продолжить ввод

0

извиняюсь, не так понял задание, я выправил в ответе как верно