Написать программу, которая вычисляет сумму первых n членов ряда 1+1/3+1/5+1/7...1/nчерез...

0 голосов
89 просмотров

Написать программу, которая вычисляет сумму первых n членов ряда 1+1/3+1/5+1/7...1/n

через оператор for to do


Информатика (34 баллов) | 89 просмотров
Дан 1 ответ
0 голосов

Var n,i:integer; s:real;
Begin
 write('n='); readln(n);
 s:=0;
 for i:=1 to (n*2)-1 do
   if (i mod 2)<>0 then s:=s+1/i;
 writeln('s=',s:0:2);
End.

(472 баллов)