Найти максимальный элемент массива X(10). помогите написать программу в паскале...

0 голосов
71 просмотров

Найти максимальный элемент массива X(10).
помогите написать программу в паскале пожалуйста.


Информатика (33 баллов) | 71 просмотров
Дан 1 ответ
0 голосов
var
X: array [1..10] of integer;
a,s,i: integer;
begin
randomize;
write('Хотите заполнить массив самостоятельно? (1) Или автоматически? (2)');
readln(s);
case s of
  1: begin
     writeln('Введите 10 элементов массива: ');
     for i:= 1 to 10 do readln(X[i]);
     a:=X[1];
      for i:= 1 to 10 do
       if a < X[i] then a:=X[i];
     writeln('Максимальный элемент: ',a);
     end;
 2: begin
     writeln('Массив: ');
     for i:= 1 to 10 do
     begin
      X[i]:=random(101);
      write(X[i]:4);
     end;
    writeln;
    a:=X[1];
     for i:= 1 to 10 do
       if a < X[i] then a:=X[i];
     writeln('Максимальный элемент: ',a);
     end;
  end;
end.     
(1.4k баллов)