C++. Напишите программу, которая вводит номер месяца и выводит название времени года **...

0 голосов
319 просмотров

C++. Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке. При вводе неверного номера месяца должно быть выведено слово 'NO'.


Информатика (57 баллов) | 319 просмотров
Дано ответов: 2
0 голосов

#include
using namespace std;

int main()
{
    cout << "Enter month num: " << endl;<br>    unsigned month = 0;
    cin >> month;
    if (month <= 12 && month >= 1) {
    switch (month / 3) {
    case 1:
        cout << "Spring" << endl;<br>        break;
    case 2:
        cout << "Summer" << endl;<br>        break;
    case 3:
        cout << "Autumn" << endl;<br>        break;
    default:
        cout << "Winter" << endl;<br>        break;
    }
    } else {
     cout << "NO" << endl;   <br>    }
return 0;
}

(4.2k баллов)
0

Спасибо большое)

0

пожалуйста, не забывайте выбрать лучший ответ)

0 голосов

#include

using namespace std;

int main(){
int x;
cin >> x;
if(x <= 0)<br>   cout << "NO"<br>else if(x < 3)
   cout << "Winter";<br>else if(x > 2 and x < 6)
   cout << "Spring";<br>else if(x > 5 and x < 9)
   cout << "Summer";<br>else if(x > 8 and x < 12)
   cout << "Autumn";<br>else
   cout << "NO;<br>return 0;
}

(582 баллов)