Помогите, пожалуйста, написать программу ** языке паскаль " Напишите программу поиска...

0 голосов
16 просмотров

Помогите, пожалуйста, написать программу на языке паскаль " Напишите программу поиска максимального из четырех чисел с использованием подпрограммы поиска большего из двух. "


Информатика (15 баллов) | 16 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var a,b,c,d: integer;
function max(a,b: integer): integer;
begin
if a>b then max:=a else max:=b;
end;
begin
readln(a,b,c,d);
if max(a,b)> max(c,d) then write(max(a,b)) else write(max(c,d));
end.

(149k баллов)
0

При выводе результата в основной программе надо что бы было 2 значений, а не 4 (a,b,c,d)

0

программа выведет не 4, а одно максимальное число

0

Это я знаю, но препод требует, что бы в программе было написано 2 значения, а не 4 при выводе, ибо "поиска большего из двух."

0

Изменил решение. Вот так надо?

0

Не знаю, но думаю что да, спасибо