1) Напишите программу, которая вводит натуральное число N и выводит первые N чётных...

0 голосов
228 просмотров

1) Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел. С++
2) Напишите программу, которая вводит натуральные числа a и b , и выводит квадраты натуральных чисел в диапазоне [ a , b ]. C++
3) Напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b . С++


Информатика (12 баллов) | 228 просмотров
Дан 1 ответ
0 голосов

1)
#include
using namespace std;

int main()
{
int n = 0;
cin >> n;
for (int i = 0; i < n; ++i) {
cout << 2 * i << endl;<br>}
return 0;
}
2)
#include
#include
using namespace std;

int main()
{
int a = 0, b = 0;
cin >> a >> b;
for (int i = a; i <= b; ++i) {<br>cout << pow(i, 2) << endl;<br>}
return 0;
}
3)
#include
#include
using namespace std;

int main()
{
int a = 0, b = 0, sum = 0;
cin >> a >> b;
for (int i = a; i <= b; ++i) {<br>sum += pow(i, 2);
}
cout << sum << endl;<br>return 0;
}

(4.2k баллов)
0

первые 2 решения неправильные

0

всмысле?

0

на засчитывает на сайте

0

ну и что я вам сделаю? так программы делают то что написано в задании, откуда мне знать что хочет ваш сайт или какие ошибки пишет, пишите тогда сами