Программа ** с++ Напишите программу, которая вводит натуральные числа a и b , и выводит...

0 голосов
135 просмотров

Программа на с++

Напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b .

Входные данные
Входная строк содержит два натуральных числа – границы диапазона a и b . Гарантируется, что a ≤ b .

Выходные данные
Программа должна вывести одно число – сумму квадратов натуральных чисел из диапазона [ a , b ] .


Информатика (96 баллов) | 135 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

#include
#include
using namespace std;

int main()
{
    int a, b, sum = 0;
    cin >> a >> b;
    for (int i = a; i <= b; ++i) {<br>        sum += pow(i, 2);
    }
    cout << sum << endl;<br>    return 0;
}

(4.2k баллов)
0 голосов

Программа для решения данной задачи 

(618 баллов)
0

#include
using namespace std;
int main()
{
int a, b, sum = 0;
cin >> a;
cin >> b;
for ( ;a <= b;a++)<br> {
sum += a * a;
}
cout << sum << endl;<br> return 0;
}