Помогите написать программу ** C++

0 голосов
43 просмотров

Помогите написать программу на C++


image

Информатика (1.1k баллов) | 43 просмотров
Дано ответов: 2
0 голосов

#include
#include
using namespace std;
int main()
{
    //объявляем стороны треугольника
    int a = 0, b = 0, c = 0;
    //вводим данные
    cin >> a >> b >> c;
    //находим полупериметр
    double p = (a + b + c) / 2;
    //находим площадь
    double s = sqrt(p*(p - a)*(p - b)*(p - c));
    cout << s << endl;<br>    return 0;
}

(4.2k баллов)
0 голосов

#include
#include

int main()
{
    float a, b, c;
    std::cout << "Введите стороны треугольника: " << std::endl; <br>    std::cin >> a >> b >> c;
    std::cout << "Площадь треугольника равна: " << sqrt(((a + b + c) / 2)*(((a + b + c) / 2) - a)*(((a + b + c) / 2) - b)*(((a + b + c) / 2) - c)) << std::endl;<br>}

(1.5k баллов)