Составьте программу, выводящую ** экран все числа от -10 до 10, а также их модули....

0 голосов
99 просмотров

Составьте программу, выводящую на экран все числа от -10 до 10, а также их модули.
Образец вывода :
Число Модуль
-10 10
-9 9
-8 8
... ...
9 9
10 10

Язык Pascal


Информатика (241 баллов) | 99 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Число Модуль');
  for var i:=-10 to 10 do
    Writeln(i:3,Abs(i):6)
end.

Пример
Число Модуль
-10    10
 -9     9
 -8     8
 -7     7
 -6     6
 -5     5
 -4     4
 -3     3
 -2     2
 -1     1
  0     0
  1     1
  2     2
  3     3
  4     4
  5     5
  6     6
  7     7
  8     8
  9     9
 10    10
(150k баллов)