Написать программу, которая вводит натуральное число и выводит следующее меню: Введите...

0 голосов
25 просмотров

Написать программу, которая вводит натуральное число и выводит следующее меню:
Введите номер задачи:
1-вычисление квадратного корня;
2-возведение в квадрат;
3-вычисление синуса;
4-вычисление косинуса;
Программа должна выполнить задание, номер которого будет введён.


Информатика (152 баллов) | 25 просмотров
0

на паскаль?

0

да

Дано ответов: 2
0 голосов
Правильный ответ

Var x:real; n:integer;
begin
write('x = ');
readln(x);
writeln('Введите номер задачи:');
writeln('1-вычисление квадратного корня;');
writeln('2-возведение в квадрат;');
writeln('3-вычисление синуса;');
writeln('4-вычисление косинуса;');
readln(n);
case n of
 1: writeln(sqrt(x):6:4);
 2: writeln(x*x:6:4);
 3: writeln(sin(x):6:4);
 4: writeln(cos(x):6:4);
 else writeln('Ошибка ввода');
end;
end.

Пример:
x = 2.1
Введите номер задачи:
1-вычисление квадратного корня;
2-возведение в квадрат;
3-вычисление синуса;
4-вычисление косинуса;
3
0.8632

(194k баллов)
0 голосов

#include
#include

int main()
{
    int x;
    std::cin >> x;
    std::cout << "Введите номер задачи: " << std::endl;<br>    std::cout << "1 - вычисление квадратного корня;" << std::endl;<br>    std::cout << "2 - возведение в квадрат;" << std::endl;<br>    std::cout << "3 - вычисление синуса;" << std::endl;<br>    std::cout << "4 - вычисление косинуса." << std::endl;<br>    int c;
    std::cin >> c;
    switch (c)
    {
    case 1:
        std::cout << sqrt(x) << std::endl;<br>        break;
    case 2:
        std::cout << x*x << std::endl;<br>        break;
    case 3:
        std::cout << sin(x) << std::endl;<br>        break;
    case 4:
        std::cout << cos(x) << std::endl;<br>        break;
    default:
        break;
    }
    std::cout << std::endl;<br>}

(1.5k баллов)