Помогите написать программу в Pascal1-e Задание

0 голосов
51 просмотров

Помогите написать программу в Pascal
1-e Задание


image

Информатика (15 баллов) | 51 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите имя и фамилию:');
  var c:=ReadlnChar('Введите символ для поиска:');
  if s.Contains(c) then Writeln('Символ в строке есть')
  else Writeln('символа в строке нет');
  var a:=s.ToWords;
  Writeln(a[0]);
  Println(a[1],a[0])
end.

Пример
Введите имя и фамилию: Петрусь Бровка
Введите символ для поиска: у
Символ в строке есть
Петрусь
Бровка Петрусь
(150k баллов)