Задания ** PascalABC. Опишите как можно подробнее ход решения. №1. Дан одномерный...

0 голосов
45 просмотров

Задания на PascalABC. Опишите как можно подробнее ход решения.

№1. Дан одномерный целочисленный массив. Определить количество чисел, кратных 5.
№2. Дан одномерный вещественный массив. Найти сумму положительных элементов, произведение элементов, индексы которых четны.
№3. Составьте программу заполнения массива, не используя клавиатуру, числами: 2, 4, 6, 8, 10, 12, 14, 16, 18, 20.

Заранее благодарю.


Информатика (17 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1) Program z1;
var a: array [1..1000] of integer;
n, c, i: integer;
begin
readln(n);
c := 0;
for i := 1 to n do readln(a[i]);
for i := 1 to n do  if (a[i] mod 5 = 0) then inc(c);
writeln(c);
readln;
end.

3) 
var a: array [1..10] of integer; 
   i: byte;
begin
for i:=1 to 10 do 
a [ i ] :=2*i;
begin
for i:=1 to 10 do   
write(a[i]:4); 
end;
end.


(386 баллов)