дан массив из семи элементов написать программу подсчитывающую среднее второго и...

0 голосов
70 просмотров
дан массив из семи элементов написать программу подсчитывающую
среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива


Информатика (170 баллов) | 70 просмотров
Дан 1 ответ
0 голосов

Тебе на поскале судя по всему надо, я его давно изучал синтаксис позабыл но алгоритм могу подсказать
1)
Var arr:массив(от 0 до 6);
begin
пока i<6 //ввод массива <br>readln(arr[i]);
конец;
writeln((i[1]+i[5])/2);//вывод среднего числа
end.
2)задача описана некорректно
3)
Var arr:массив(от 0 до 29),n:integer;
begin
пока i<30 //ввод массива <br>readln(arr[i]);
конец;
пока j<29<br>n=n+arr[j];
конец;
writeln(N/30);//вывод среднего числа
end.

(451 баллов)
0

дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 или 5))реши пожалуйста и это,я не разбираюсь в этом вообще((

0

я не понимаю суть задачи, что значит красных 3 и 5

0

кратных:DD сори))

0

Var arr:массив(от 0 до 9),n:integer;
begin
пока i<9 //ввод массива <br>readln(arr[i]);
конец;
пока j<9<br>если arr[j]делится на 3 или 5 то
конец;
writeln(N/30);//вывод среднего числа
end.

0

бло

0

СПАСИБО!!!!