Программа ** с++ Напишите программу, которая вводит четыре натуральных числа (a, b, c и...

0 голосов
263 просмотров

Программа на с++

Напишите программу, которая вводит четыре натуральных числа (a, b, c и d) и находит все пятизначные числа, которые при делении на a дают в остатке b , а при делении на c дают в остатке d .

Входные данные
Первая входная строка содержит два натуральных числа, разделённые пробелами: a и b. Вторая строка содержит натуральные числа c и d, также разделённые пробелом. Гарантируется, что 0 ≤ b ≤ a и 0 ≤ d ≤ c.

Выходные данные
Программа должна вывести в одну строчку через пробел все пятизначные натуральные числа, которые при делении на a дают в остатке b, а при делении на c дают в остатке d . Если таких чисел нет, программа должна вывести число -1.


Информатика (324 баллов) | 263 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;

int main(){
int a,b,c,d,o=0;
cin>>a>>b>>c>>d;
for (int i=10000; i<=99999;i++)<br>  if (i % a ==b && i % c == d)
  {
        cout<<i<<' ';<br>  o=1;
  }
if (o==0)
    cout<<-1;<br>}

(3.6k баллов)