Дан массив из n чисел. Составить программу для вычисления суммы элементов массива,...

0 голосов
48 просмотров

Дан массив из n чисел. Составить программу для вычисления суммы элементов массива, имеющих чётные индексы. Паскаль


Информатика (20 баллов) | 48 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  Write('Сумма элементов с четными индексами ',
      a.Where((x,i)->i.IsOdd).Sum)
end.

Пример
n= 13
81 6 -34 -33 -13 86 -14 -49 -28 -20 -93 5 -62
Сумма элементов с четными индексами -5
(150k баллов)