Составить программу, которая позволяет найти сумму первой и третьей цифры в...

0 голосов
35 просмотров

Составить программу, которая позволяет найти сумму первой и третьей цифры в четырехзначном числе.


Информатика (14 баллов) | 35 просмотров
0

на каком языке?

0

с++

Дано ответов: 2
0 голосов

Program test_sum;
begin
var inp_num : integer;
readln (inp_num);
var a, b : integer;
a := inp_num[0];
b := inp_num[2];
var res := a + b;
writeln ("Сумма 1 и 3 цифры равна: ", res);
end.

(292 баллов)
0 голосов

#include

using namespace std;

int main(){
system("chcp 1251");
int n;

cout<<"введите 4-значное число";<br>cin >> n;

int first = n/1000; // первая цифра
int third = (n%100)/10;

cout << "\nОтвет = " << first + third << endl;<br>system("pause");
}

(732 баллов)