Программа ** с++ Дан массив, состоящий из целых чисел. Напишите программу, которая...

0 голосов
46 просмотров

Программа на с++

Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).

Входные данные
Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.

Выходные данные
Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Примеры
входные данные
5
1 2 3 4 5

выходные данные
4


Информатика (324 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include

using namespace std;

int main() {
 int n;
cin >> n;
int *arr = new int[n];

for (int i = 0; i < n; i++) {
 cin >> arr[i];
}

int counter=0;
for (int i = 1; i < n; i++) {
 if (arr[i] > arr[i-1]) {
  counter++;
 }
}
cout << counter;<br> return 0;
}

(732 баллов)