Помогите с информатикой Напишите программу, которая запрашивает четырёхзначное число,...

0 голосов
170 просмотров

Помогите с информатикой

Напишите программу, которая запрашивает четырёхзначное число, разрезает его пополам и выводит половинки через пробел.

Sample Input 1:
1234
Sample Output 1:
12 34
Sample Input 2:
1200
Sample Output 2:
12 00


Информатика (155 баллов) | 170 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

PascalABC.NET 3.3
begin
  write(ReadChar, ReadChar, ' ', ReadChar, ReadChar)
end.

(148k баллов)
0

Это как-то следует из того, что вы написали в задании? Всё это стоит указывать сразу, иначе какие претензии ¯\_(ツ)_/¯

0

Я не понимаю просто почему там 12 0 а не 12 00

0

Когда выводите вторую половинку, проверяйте, что она больше 9, иначе нужен дополнительный 0 вывести.

0

Там когда код проверяется вводится и 1234 и 1200

0

могу скинуть урок

0

Скиньте, но если ссылкой - лучше в личку, в открытом доступе ссылки публиковать нельзя.

0

Я в личку не могу

0

Вроде бы можно ссылку дать ее просто скопировать

0

Нам учитель информатики не объяснил как делать такие задания ... Я не могу понять