Задание 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение...

0 голосов
493 просмотров

Задание 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). Задание 2. Напишите программу, которая запрашивает два целых числа x и y, после чего вычисляет и выводит значение x в степени y. Задание 3. Найти среднее арифметическое всех целых чисел от 1 до 1000. Задание 4. Найти произведение всех целых чисел от a до 20 (значение a вводится с клавиатуры: 1 <=a <= 20). Задание 5. Написать программу, которая выводит на экран таблицу умножения на k, где k – номер варианта. Например, для 7-го варианта: 7 x 2 = 14 7 x 3 = 21


Информатика (23 баллов) | 493 просмотров
0

pascal или C++?

Дан 1 ответ
0 голосов
Правильный ответ

1.
#include
using namespace std;
void main()
{
    //задаём русский язык для консоли
    setlocale(LC_ALL, "Russian");
    long sum = 0;
    int a;
    cout << "Введите a" << endl;<br>    cin >> a;
    if (a > 500)
    {
        cout << "а > 500" << endl;<br>    }
    else
    {
        sum = (500 * 501 / 2) - ((a - 1) * a ) / 2;
        cout << sum;<br>    }
}
2.
#include
using namespace std;
void main()
{
    //задаём русский язык для консоли
    setlocale(LC_ALL, "Russian");
    double average = (1 + 1000) / 2.;
    cout << "Среднее арифметические чисел от 1 до 1000" << average << endl;<br>}
3
#include
using namespace std;
void main()
{
    //задаём русский язык для консоли
    setlocale(LC_ALL, "Russian");
    int a = 0, b = 0;
    cout << "Введите границы диапазона" << endl;<br>    cin >> a >> b;
    cout << "Все числа:" << endl;<br>    if (a <= b)<br>    {
        for (int i = a; i <= b; i++)<br>        {
            cout << i << endl;<br>        }
    }
    else
    {
        for (int i = b; i < a; i++)
        {
            cout << i << endl;<br>        }
    }
    cout << "Чётные числа:" << endl;<br>    if (a <= b)<br>    {
        for (int i = a; i <= b; i++)<br>        {
            if (i % 2 == 0)
            {
                cout << i << endl;<br>            }
        }
    }
    else
    {
        for (int i = b; i < a; i++)
        {
            if (i % 2 == 0)
            {
                cout << i << endl;<br>            }
        }
    }
    cout << "Нечётные числа:" << endl;<br>    if (a <= b)<br>    {
        for (int i = a; i <= b; i++)<br>        {
            if (i % 2 != 0)
            {
                cout << i << endl;<br>            }
        }
    }
    else
    {
        for (int i = b; i < a; i++)
        {
            if (i % 2 != 0)
            {
                cout << i << endl;<br>            }
        }
    }
    cout << "Числа, кратные 7:" << endl;<br>    if (a <= b)<br>    {
        for (int i = a; i <= b; i++)<br>        {
            if (i % 7 == 0)
            {
                cout << i << endl;<br>            }
        }
    }
    else
    {
        for (int i = b; i < a; i++)
        {
            if (i % 7 == 0)
            {
                cout << i << endl;<br>            }
        }
    }
}
4. 
#include
using namespace std;
void main()
{
    //задаём русский язык для консоли
    setlocale(LC_ALL, "Russian");
    int a = 0, sum = 0;
    cout << "Введите числа" << endl;<br>    while (true)
    {
        cin >> a;
        if (a == 0)
        {
            break;
        }
        sum += a;
    }
    cout << "Сумма =" << sum << endl;<br>}

(513 баллов)