Написать программу, которая вычисляет и печатает объемы цилиндров высотой h=20 и...

0 голосов
169 просмотров

Написать программу, которая вычисляет и печатает объемы цилиндров высотой h=20 и радиусами оснований от 1 до 15.
НАПИСАТЬ ПРОГРАММУ НУЖНО В ПАСКАЛЕ


Информатика (83 баллов) | 169 просмотров
Дан 1 ответ
0 голосов
var
  h, i: byte;
  z: real;
begin
  h := 20;
  for i := 1 to 15 do
    writeln('Объем цилиндра с основанием ', i, ' = ', (pi * (i * i) * h):2:2);
end.



image
(9.4k баллов)
0

спасибо большое, можешь мне объяснить как это вообще делается, а то я к оге подготавливаюсь и не могу понять как это всё делается

0

Отредактировал программу. Первый раз перепутал формулу.

0

Это основы основ, как 2 + 2. Я незнаю как это объяснять.

0

а какую ?

0

блин

0

ну ладно спасибо всё равно

0

pi * (i * i) * h это формула для вычисления объема цилиндра по высоте и радиусу основания.

0

i = радиус основания. h = высота цилиндра. pi = число пи. i * i = квадрат числа i, т.е. квадрат радиуса основания.

0

спасибо