Составить программу, которая выводит ** экран вопрос: «Какой предмет вы любите?» и после...

0 голосов
209 просмотров
Составить программу, которая выводит на экран вопрос: «Какой предмет вы любите?» и после ответа (например, «информатика») выдает сообщение: «Информатика - самый важный предмет!

Информатика (12 баллов) | 209 просмотров
Дано ответов: 2
0 голосов

Uses crt;
var s:string;
begin
writeln('Какой предмет вы любите?');
read(s);
writeln(s,' - самый важный предмет!');
end.

(8.2k баллов)
0

спасибо)только как-то странно написано

0

А что не так?

0

мне на английском..но в школе мы по другому пишем

0

Да.

0

Это вроде pascal?

0

Вам на каком языке программа нужна?

0

что эти слова означают,объясни пжл))))

0 голосов
#include

using namespace std;
int main()
{ 

      int subject;
   
cout << "</span>Какой предмет вы любите: ";  
cin >> subject;
  
cin.ignore();
 
cout << "</span>Информатика - самый важный предмет! "<< "\n";<span>  cin.get();

}
(52 баллов)
0

Ну извини..учусь на C++ только ._.

0

Это языки pascal и c++, на которых программы могут реально работать. В таком случае извините, я не знаю, что вы там делаете.

0

ну не знаю..мы в классе там делаем..а это на каком?

0

Программу на английском? Может я что - то недопонял, но о таком языке программирования я не слышал.

0

помогите еще))))1.Составьте программу ввода и вывода
1.Составьте программу ввода и вывода массива:5,-2,3,-6,7,9,-4,8,1,2,7,-3

2.Составьте блок-схему алгоритма и программу вычисления в массиве А(10) количества положительных элементов.

3.Составьте программу уменьшения всех элементов массива на 4

0

Не знал. Да не за что, удачи в изучении. Если учишься по урокам в интернете - все херня - возьми одну книгу (Лафоре или Страуструпа), и по ней изучай азы. Только так можно организовать крепкую базу знаний. Ну это так - совет из опыта.

0

Спасибо что подсказал ^^

0

Кстати, а в вашем коде смысл в данном случае cin.ignore() ? И еще, правильно будет cout<<subject<<" ляляля "<<endl; (ну или "\n").

0

Если*

0

помоги еще))))1.Составьте программу ввода и вывода
1.Составьте программу ввода и вывода массива:5,-2,3,-6,7,9,-4,8,1,2,7,-3

2.Составьте блок-схему алгоритма и программу вычисления в массиве А(10) количества положительных элементов.

3.Составьте программу уменьшения всех элементов массива на 4