Как написать программу для паскаля которая считает площадь квадрата??????

0 голосов
83 просмотров

Как написать программу для паскаля которая считает площадь квадрата??????


Информатика (12 баллов) | 83 просмотров
Дано ответов: 2
0 голосов

Квадрат вписан в круг. 
Нужно написать програмку, которая считает площадь окружности, если ввести сторону квадрата 

У меня вышла формула : 

S окр = ((a^2)/2) * (P(число пи)-2) - Площадь круга минус площадь квадрата 

вот код : 

Program Okruzhnost; 
Var 
x,y: real; 
S: real; 

Procedure RectS(a,b: real; Var S:real); 
Begin 
S := (((sqr(x))/2) * (pi-2)); 
end; 

Begin 
WriteLn('Введите сторону квадрата'); 
ReadLn(x,y); 
RectS(x,y,S); 
WriteLn('Площадь окружноси равна',S); 

end.


image
(100 баллов)
0

мне надо именнно только для площади квадрата

0

Извини, не знаю

0

блин,мне срочно нужно

0 голосов

Var a,S:integer;
Begin
 writeln('введите сторону квадрата');
 readln(a);
 S:=a*a;
writeln('Площадь = ',S);
readln;
end.

(471 баллов)
0

спасибо)))))