Составить программу которая формирует массив из 15 случайных целых чисел из отрезка от...

0 голосов
47 просмотров

Составить программу которая формирует массив из 15 случайных целых чисел из отрезка от -10 до 10. На экран вывести исходный массив и найденный результат.
а) Найти среднее арифметическое всех элементов массива.
б) Вычеслить среднее арифметическое положительных (отрицательных) элементов массива.


Информатика (22 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Var
a: array [1..15] of integer;
avg, avgpol, avgotr: real;
i, k1, k2: byte;
begin 
avg := 0; avgpol := 0; avgotr := 0; 
writeln('Massiv:'); 
Randomize; 
for i:=1 to 15 do 
begin 
a[i]:=random(20)-10; 
write(a[i], ' '); 
avg:=avg + a[i]; 
if a[i] > 0 then     
begin       
avgpol := avgpol + a[i];       
inc(k1);     
end; 
if a[i] < 0 then     
begin       
avgotr := avgotr + a[i];       
inc(k2);     
end; 
end; 
avg:=avg/15; 
avgpol:= avgpol/k1; 
avgotr:= avgotr/k2; 
writeln; 
writeln('Srednee massiva = ', avg:3:2); 
writeln('Srednee polozh. elementov = ', avgpol:3:2); 
writeln('Srednee otric. elementov = ', avgotr:3:2); 
readln;
end.

(474 баллов)