Написать программу ** с++, очень надо

0 голосов
17 просмотров

Написать программу на с++, очень надо


image

Информатика (219 баллов) | 17 просмотров
Дан 1 ответ
0 голосов

#include
#include
using namespace std;

int main()
{
float a(1.23f), xn(-0.5f), xk(0.5f), dx(0.1);
float x(xn), sum(0.f), com(1.f), t(0.f);
int n = 0;

do {
x += dx;
t = (pow(a * x, 1 / 3)) / ((a + x) * log(a + x));
if (t > 0) {
sum += t;
}
if (t < 0) {
com *= t;
n++;
}
} while (x < xk);
cout << "Summa: " << sum << endl;<br>cout << "Proizvdenie: " << com << endl;<br>cout << "Kol-vo otricatelnyh: " << n << endl;<br>return 0;
}
https://ideone.com/yZkcYU

(4.2k баллов)