Составьте программу которая заполняет массив A состоящая из 20 случайных целых чисел в...

0 голосов
51 просмотров

Составьте программу которая заполняет массив A состоящая из 20 случайных целых чисел в диапазоне от 1 до 30 и выводит на экран элементы значения которых являются чётными и кратными трём


Информатика (21 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

Program rand;
var i:integer;
A:array[1..20] of integer;
begin
randomize;
for i:=1 to 20 do
begin
A[i]:=random(30,1);
if (A[i] MOD 3=0) and (A[i] MOD 2=0) then
write(A[i],' ');
end;
end.

(8.2k баллов)
0

Если нужно, чтобы рандомные числа не повторялись, могу немного переделать код.

0

Спасибо большое за решение!!!

0

Да пожалуйста.