Напишите программу которая вычисляет сумму первых n натуральных чисел

0 голосов
28 просмотров

Напишите программу которая вычисляет сумму первых n натуральных чисел


Информатика (56 баллов) | 28 просмотров
Дан 1 ответ
0 голосов

Var s, i, : integer:
Begin
s:=0
readin(n)
for i:= 1 to n do s:s+i
writeln(s)
end
(457 баллов)
0

это все? а там же что то про число n

0

var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+(i*i);
writeln(s);
end.

в) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do
begin
if (i mod 2 = 0) then s:=s+i;
end;
writeln(s);
end.

г) var s, i :integer;
begin
s:=0;
for i:= 10 to 99 do s:=s+i;
writeln(s);
end.

0

там чтотоо не правильно. где integer там пишет ожидался идентификатор

0

Чего

0

Там Integer в каком смысле ожидался индификатор