Написать программу в С++, которая проверяла бы:"Число армстронга или нет". Если что,...

0 голосов
71 просмотров

Написать программу в С++, которая проверяла бы:"Число армстронга или нет".
Если что, число армстронга-это число в котором сумма цифр=самому числу. Причем каждая цифра в таком степени, сколько цифр в самом числе, например число 153-армстронга, потому что 153=1³+5³+3³. Если можно,напишите программу так, чтоб я, как новичок понял, плииииз))))). РЕШИТЬ ЧЕРЕЗ ФУНКЦИИ.


Информатика (46 баллов) | 71 просмотров
Дан 1 ответ
0 голосов

#include
#include
using namespace std;

void isArmstrong(const int number)
{
int origNum, num, rem, sum = 0;
origNum = number;
num = origNum;
while(num != 0) {
rem = num % 10;
sum += pow(rem, 3);
num /= 10;
}

if(sum == origNum)
cout << origNum << " is an Armstrong number.";<br>else
cout << origNum << " is not an Armstrong number.";<br>}

int main()
{
isArmstrong(153);
return 0;
}
_________________________
С проверкой https://ideone.com/keY6PS

(4.2k баллов)