В питоне Напишите программу, которая определяет, является ли заданная строка (возможно,...

0 голосов
249 просмотров

В питоне
Напишите программу, которая определяет, является ли заданная строка (возможно, содержащая пробелы) палиндромом, то есть верно ли, что она после удаления пробелов читается одинаково слева направо и справа налево. Входные данные Входная строка – последовательность символов, возможно, содержащая пробелы. Выходные данные Программа должна вывести слово 'YES', если введённая строка – палиндром, и слово 'NO', если она не является палиндромом. Примеры входные данные ka za k выходные данные YES входные данные kaza n выходные данные NO Сдать:


Информатика (340 баллов) | 249 просмотров
Дан 1 ответ
0 голосов

НА ПРИМЕРЕ В ЭТОЙ ЗАДАЧИ 

program z1;
uses crt;
const
st1='ма';
st2='ма';
var
str:string;
i,k:integer;
begin
write('введите строку: ');readln(str);
for i:=1 to length(str) do
if (st1=copy(str,i,2)) or (st2=copy(str,i,2)) then
k:=k+1;
writeln(k);
end. 

(215 баллов)