Помогите, пожалуйста, написать программу в паскале!!
Var i, k: integer; s: real; begin s := 1; for i := 1 to 10 do begin k := k + i; s := s * k; writeln(i:3,k:3,' ',s); end; writeln(s); end.
какой ответ?
ой неправильно чо-то посчитала как всегда
скорее всего у Расты ошибка в рассчетах, ведь цифры весьма похожи
как и у меня
у меня 141455160000
если по задаче вычислять, то должно выйти 141455160000
должно получиться 144598608000
просто складывала и умножала, как и нужно в задании
все равно не получается
да-да, у вас правильно спасибо большое! можете еще посмотреть задачки? http://znanija.com/task/3974660
Program zadacha; var i:integer; s,p:longint; begin s:=1; p:=1; for i:=2 to 10 do begin p:=p+i; s:=s*p; end; write(s); end.
почему получается отрицательное число??
переполнение стека
real хватает
можно попробовать Int64, только нужно использовать free pascal.
ясно, спасибо
данные больше чем максимальное значение возможное для этого типа и оно переходит в минуса
эм?