Написать программу ** языке паскаль, в которой определяется какому времени года...

0 голосов
43 просмотров

Написать программу на языке паскаль, в которой определяется какому времени года принадлежит введённый с клавиатуры порядковый номер месяца.За основу взято международное соглашение январь-1; декабрь-12.


Информатика (15 баллов) | 43 просмотров
0

на c# есть смысл писать? поймешь алгоритм?

0

Да

0

Могу написать на паскале, написать?

0

Буду очень признательна)

Дано ответов: 2
0 голосов
Правильный ответ

Var a:integer;
Begin
  Write('Введите номер месяца: '); readln(a);
case a of
1:writeln('Январь - Зима');
2:writeln('Февраль- Зима');
3:writeln('Март- Весна');
4:writeln('Апрель- Весна');
5:writeln('Май- Весна');
6:writeln('Июнь-Лето');
7:writeln('Июль- Лето');
8:writeln('Август- Лето');
9:writeln('Сентябрь-Осень');
10:writeln('Октябрь -Осень');
11:writeln('Ноябрь- Осень');
12:writeln('Декабрь - Зима');
else writeln('Введено не верное число. Введите число от 1 до 12');
end;
end.


Либо упрощённый вариант:
Var a:integer;
Begin
Write('Введите номер месяца: '); readln(a);
case a of
1..2:writeln('Зима');
3..5:writeln('Весна');
6..8:writeln('Лето');
9..11:writeln('Осень');
12:writeln('Зима');
else writeln('Введено не верное число. Введите число от 1 до 12');
end;
end.

(8.6k баллов)
0

Я бы тоже case взял, но посмотри, там время года, а не месяца

0

немного ошибся)

0

а так сойдёт?)

0

во, другое дело

0

можно было сделать так: "1..3:write('зима');" это бы сократило кол-во строк, но не писало бы времена года

0

то есть не писало бы название месяйца*

0

щас напишу упрощёный вариант кода

0

Огромное спасибо)

0

Var a:integer;
Begin
Write('Введите номер месяца: '); readln(a);
case a of
1..2:writeln('Зима');
3..5:writeln('Весна');
6..8:writeln('Лето');
9..11:writeln('Осень');
12:writeln('Зима');
else writeln('Введено не верное число. Введите число от 1 до 12');
end;
end.

0 голосов

Int mesyac;
Console.WriteLine("Введите месяц:");
mesyac = Convert.ToInt32(Console.ReadLine());
if (mesyac == 12 || mesyac == 1 || mesyac == 2)
{
Console.WriteLine("Зима");
}
if (mesyac > 2 && mesyac =< 5)
{
Console.WriteLine("Весна");
}
if (mesyac > 5 && mesyac =< 8)
{
Console.WriteLine("Лето");
}
if (mesyac > 8 && mesyac =< 11)
{
Console.WriteLine("Осень");
}
Console.ReadKey());

(625 баллов)
0

ошибочку допустил, ща исправлю

0

всё так сложно когда смотришь на не знакомый язык и всё так легко когда смотришь на свой паскаль, который знаешь :D