Помогите 25 баллов. 7)Составить программу, которая по заданному "a" исследует корни...

0 голосов
46 просмотров

Помогите 25 баллов.
7)Составить программу, которая по заданному "a" исследует корни уравнения "ax=5" и выводит на экран значение вычисленного корня а если нет то сообщение (Корней нет).


Информатика (15 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a:real;
begin
readln(a);
if a=0 then writeln('Корней нет')
else writeln('x = ',5/a:4:2);
end.

Пример:
4
x = 1.25

(194k баллов)