Прошу решите ** PascalABC или Phyton Дано натуральное число. Требуется разделить запятыми...

0 голосов
64 просмотров

Прошу решите на PascalABC или Phyton
Дано натуральное число. Требуется разделить запятыми тройки его цифр(считая справа).
Входные данные содержат натуральное число, не превосходящее 10 в 100
Выходные данные. То же число, разделяя тройки цифр запятыми.
Примеры:
Входные Выходные
1000 1,000
12345 12,345


Информатика (14 баллов) | 64 просмотров
Дан 1 ответ
0 голосов

Var n: integer;
 s: string;
begin
  write('Введите строку символов ');
  readln(s);
  n:=Length(s);
  for var i:= 1 to ((n-1) div 3) do
   insert(',',s,n-3*i+1);
  writeln(s);
end.
-----------
АБС паскаль.
типа данных для 100 цифр числа нет, поэтому вводим в строковый тип, и поэтому всё равно, что бить по три, цифры или буквы.

(32.2k баллов)
0

Спасибо