"Дана строка символов T. Напишите программу, которая добавит перед и после каждой гласной...

0 голосов
48 просмотров

"Дана строка символов T. Напишите программу, которая добавит перед и после каждой гласной буквой строки – букву ‘p’. Например, ‘corectitudine’ станет ‘cpoprpepctpiptpupdpipnpep’. "Написать на C++


Информатика (42 баллов) | 48 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
#include
#include
 
using namespace std;
int main()
{
 string t, s="";
 cout << "t = ", cin >> t, cout << endl;<br>  set a = {'a','e','i','o','u','y'};
 for(int i=0; i   if(a.find(t[i]) == a.end()) s = s+t[i];
  else s = s+'p'+t[i]+'p';
 cout << s << endl;<br>  return 0;
}

Пример:
t = corectitudine
cpoprpepctpiptpupdpipnpep
(194k баллов)