Написать программу,которая вычисляет сумму первых n-натуральных чисел....

0 голосов
53 просмотров

Написать программу,которая вычисляет сумму первых n-натуральных чисел.
Помогите!!!!!!!
Должны быть операции while и do


Информатика (112 баллов) | 53 просмотров
0

Первый год информатика только пошла, уже программирование

0

Тружновато все же детям

0

Кто-нибудь бы помог и объяснил

0

Хотя бы кратко

0

Большое спасибо)

Дан 1 ответ
0 голосов
Правильный ответ

Var
  i,n,s:integer;
begin
  Write('n='); Read(n);
  s:=0; i:=1;
  while i<=n do begin<br>    s:=s+i;
    i:=i+1
    end;
  Writeln('Сумма равна ',s)
end.

Пример
n=10
Сумма равна 55

(150k баллов)
0

Я понимаю, но учителям в школе надо было хоть бы элементарному нас научить, а тут приходим и программирование

0

Наверно, так и придется делать

0

Но надо начинать с азов)

0

Это, да, совершенно верно

0

Давайте)