Помогите написать программу (в паскале) к задаче:Вычислить диагональ прямоугольника если...

0 голосов
54 просмотров

Помогите написать программу (в паскале) к задаче:Вычислить диагональ прямоугольника если известна меньше сторона, а большая сторона в 3 раза больше за меньшую


Информатика (18 баллов) | 54 просмотров
Дан 1 ответ
0 голосов

//PascalABC.NET

begin
    write('Длина меньшей стороны: ');
    var a := ReadlnReal;
    writeln('Длина диагонали равна ', sqrt(a*a+ 9*a*a):8:3)
end.


image
(5.6k баллов)
0

спасибо большое

0

Или чуть короче: sqrt(10*a*a) :D